Ett bilde vil ikke være med!?

harkruha
harkruhas bilde
Avlogget
Ble med: 02.08.2012

Hei.

Holder på å kode min første webside med HTML/CSS og alt har gått relativt bra. Men nå når jeg begynner å nærme meg ferdig med design osv har det dukket opp ett problem. Når jeg ser på filene lokalt på pcen min er alt i orden, men når jeg laster opp filene via FileZilla så er det ett viktig bilde i designet som ikke vil vise seg på siden. Bildet ligger i samme mappe som resten av bildene og jeg har sjekket flere ganger at bildet ligger der det skal. Da skjønner jeg virkelig ikke hva problemet kan være. Er det noen som kan hjelpe meg?

 - Harald 

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Ett bilde vil ikke være med!?

Kan du vise meg koden du bruker for å vise bildet, og hvor du har lagt bildet på selve webserveren?

Jeg vil gjerne se både HTML og CSS-kodene du har brukt for å plassere bildet – gitt at du har brukt CSS og ikke <img>-taggen i HTML, selvsagt.

Når det gjelder hvor du har lagt bildet på webserveren, så gi meg absolutt filbane i forhold til webrooten. Hvis bildet ligger i katalogen "/bilder/" inne i webrooten din, for eksempel.

harkruha
harkruhas bilde
Avlogget
Ble med: 02.08.2012
Ett bilde vil ikke være med!?

Hei.

Koden jeg har for å vise bildet er:

  1. <div id="splash">
  2. <img src="images/banner.png" width="1100" height="250" alt="" />
  3. </div>

i CSS står det følgende om #splash

  1. #splash {
  2. padding: 40px;
  3. position: relative;
  4. background: #FFF;
  5. margin: 20px 0 0 0;
  6. height: 250px;
  7. width: 1100px;
  8. box-shadow: 0px 0px 5px 0px rgba(0,0,0,0.25);
  9. }

Skal innrømme att CSS'en er laget av http://www.freecsstemplates.org/ så jeg forstår ikke så mye av det som står der:

Om du skal se siden så lastet jeg opp litt av den så du kan se hva som mangler: siden min finner du her: http://www.kolbotnhunters.com/

Håper du har mulighet til å fikse det! Takk på forhånd.

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Ett bilde vil ikke være med!?

Det gjør ikke noe at du lager templatet med en annen tjeneste. Kan jo være en fin måte å lære på det også.

Er du sikker på at bildet ditt "banner.png" er lastet opp på webserveren da? Du refererer til at det skal ligge i "/images/banner.png", men det ligger ikke noe bilde ved det navnet i den katalogen.

Det ligger imidlertid ett ved navn "Banner.png" der. Webhotellet ditt er på en Linux-server, og i UNIX så er det forskjell på filnavn med store og små bokstaver.

Navnekonvensjoner på UNIX

Jeg anbefaler at alle filene du bruker til websiden din navngis med

  • Små bokstaver
  • Uten mellomrom, erstatt mellomrom med bindestrek!
  • Ingen spesialtegn type æ, ø, å

Løsning på ditt problem

Hvis du renamer bildet til "banner.png" først, og endrer HTML-koden til å bruke absolutte filbaner, slik;

  1. <img src="/images/banner.png" width="1100" height="250" alt="" />

så vil bildet mirakuløst nok dukke opp! smil

harkruha
harkruhas bilde
Avlogget
Ble med: 02.08.2012
Ett bilde vil ikke være med!?

Tusen takk! HjemmesideGuru redder dagen igjen glis

Svar på forumemnet

(If you're a human, don't change the following field)
Your first name.
Innholdet i dette feltet blir holdt privat og vil ikke bli vist offentlig.