Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2).

husisolering
husisolerings bilde
Avlogget
Ble med: 19.03.2010

Hei, igjen

Fikk denne meldingen der hvor jeg skal velge språk i drupal på hjemmesiden min: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2).

Har prøvd å sjekke om hva som er det brukernavnet og passordet som gjelder, for så å taste det inn i context, men ingneting løser problemet. Når jeg sjekker i kontrollpanelet på min side his web10, blir jeg ikke helt klok.

Hvor kan jeg finne det msql brukernavnet og passordet som gjelder?

Mvh Jonas

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Manglende katalog og MySQL

Når jeg går inn på domenet ditt får jeg spørsmål om språk. Hvis jeg velger norsk så går jeg videre til neste trinn.

Her får jeg beskjed om å opprette katalogen "files" under sites/default. Hvis du allerede har katalogen "files" der, overse trinn 1.

Løs problemet på denne måten:

  1. Logg på webhotellet med FTP, bla deg inn i sites/default og opprett mappen "files".
  2. Høyreklikk på katalogen og velg File permissions, tillatelser eller lignende.
  3. Skriv inn tallene 777 og velg så innstillingene skjer på filer og kataloger under katalogen "files".

Prøv å starte installasjonsprosessen igjen.

Brukernavn og pass til MySQL

Hos din webhost er det vanlig at hostname blir db.dittdomene.no

Navnet på databasen og brukernavnet til databasen er det samme. Både brukernavnet og navnet på databasen er å finne i velkomstmailen du mottok da du kjøpte webhotellet. Det samme gjelder passord.

Oppdater settings.php under sites/default med disse opplysningene eller gå inn i sites/default og sett file permissions til 777, start installasjonsprosessen, skriv inn databasedetaljer under installasjonen og gå tilbake til settings.php og gi den file permissions 644 igjen.

husisolering
husisolerings bilde
Avlogget
Ble med: 19.03.2010
har gjort det du beskrev

har gjort det du beskrev ovenfor, men det funket ikke

Ser dette riktig ut?:

 * Database URL format: *   $db_url = 'mysql://username:password@localhost/databasename'; *   $db_url = 'mysqli://username:password@localhost/databasename'; *   $db_url = 'pgsql://username:password@localhost/databasename'; */$db_url = 'mysql://username:password@localhost/databasename';$db_url = 'mysql://(skjult):(skjult)@db_dittdomene_no/husisolering_no';$db_prefix = '';

------------------------------------------------------------------

her er hva web10 sier angående dette:

----------------------------------------------------------

Du skal koble til den nye databasen med hostnavn: db.dittdomene.no Eks. Host: db.dittdomene.no Brukernavn: wno1234 Pass: abc123def Db: wno1234 Du kan finne de riktige tallene i velkomstmailen din.

--------------------------------------------------------------------------------------

 

Mvh jonas

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Du har ikke gjort riktig

Nei, du har nok ikke gjort det helt riktig. I din linje har du;

<?php
$db_url
= 'mysql://(skjult):(skjult)@db_dittdomene_no/husisolering_no';
?>

her skal du ha det på denne formen;

<?php
$db_url
= 'mysql://brukernavn:passord@hostname.tld/databasenavn';
?>

Brukernavnet, passordet, hosten og databasenavnet fikk du i velkomstmailen. De skal skrives på akkurat den formen som de fremsto i denne e-posten.

Rediger denne linjen om det blir klarere for deg;

<?php
$db_url
= 'mysql://brukernavn:passord@db.dittdomene.no/databasenavn';
?>

Webhosten din sier at brukernavn og databasenavn er likt. Du bruker understrek, men grunnen til at jeg bruker understrek i videoen er fordi den databasen jeg bruker der er navngitt ved underscore.

Så prøv dette, så skal du nok se at ting går veien :)

husisolering
husisolerings bilde
Avlogget
Ble med: 19.03.2010
'reading initial communication packet', system error: 61

Hei. jeg har prøvd utallige ganger, men jeg kommer ikke videre.

På faq på web10 sine sider står det følgende om oppsett av mysql på unix:

6 - MySQL (UNIX)Du skal koble til den nye databasen med hostnavn: db.dittdomene.no Eks. Host: db.dittdomene.no Brukernavn: wno1234 Pass: abc123def Db: wno1234 Du kan finne de riktige tallene i velkomstmailen din.

Ifølge eksempelet over, vil da følgende linje være riktig?

$db_url = 'mysql://wno1234:abc123def@db.dittdomene.no/wno1234' ;

--------------------------------------------------------------------------------------------------------

Dette har jeg nå skrevet inn, men får da følgende opp: 

Failed to connect to your MySQL database server. MySQL reports the following message: Lost connection to MySQL server at 'reading initial communication packet', system error: 61

Hva kan problemet være?

Mvh Jonas

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Feilmeldinger

Så uheldig du er. Dette problemet har ikke noe med Drupal å gjøre, men MySQL og kommunikasjonen med den. Den gode nyheten er i alle fall at du får kontakt med serveren.

Forsøk å bruke "localhost" i steden for hosten db.dittdomene.no først. Hvis ikke det fungerer prøv dette:

  1. Fjern settings.php
  2. Kopier default.settings.php til settings.php
  3. Med FTP sett file permissions til 777 på settings.php (høyreklikk på fila)
  4. Start installasjonsprosessen på nytt
  5. Skriv inn databasedetaljene når du installerer Drupal

Hvis dette leder til samme error, ta kontakt med webhosten din og hør hvorfor du får opp denne feilmeldingen. Referer gjerne til denne tråden.

Alternativt kan du la meg prøve litt, men da må du sende meg brukernavn og passord for kontrollpanelet ditt, samt. til FTP og MySQL. Da skal jeg drille litt ned i dette for å se hvor problemet kan ligge. Blir ikke fornærmet om du takker nei.

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Feil passord

Du sendte meg epost med pålogging til kontrollpanelet ditt. Det første jeg forsøkte var å logge på phpMyAdmin med brukernavnet og passordet som var oppgitt under MySQL i kontrollpanelet ditt, det fungerte ikke.

Brukernavnet du sendte meg var likt for pålogging til både MySQL via phpMyAdmin og til selve kontrollpanelet, men passordet var forskjellig.

Prøvde likevel å bruke passordet du sendte meg for å logge på phpMyAdmin, og det fungerte. :) Det har tydeligvis skjedd noe galt på webhotellet ditt, for passordet de angir å være riktig for MySQL er ikke riktig.

Brukte så dette passordet under installasjonen av Drupal, så nå er du klar for å logge på med brukernavn og epost som jeg sendte deg via epost.

husisolering
husisolerings bilde
Avlogget
Ble med: 19.03.2010
Heilt konge

Dette er ubeskrivelig bra.

 

Tusen takk!

 

Nå skal jeg se videre på videoene om utforming av hjemmesiden.

 

Mvh Jonas

GonWild
GonWilds bilde
Avlogget
Ble med: 16.02.2011
samme problem

Hei, lagde i går en egen tråd om dette, men har egentlig samma problemet...

Får opp denne feilen når jeg skriver inn databasenavn i Drupal: SplFileInfo::isWritable() [splfileinfo.iswritable]: Unable to find the wrapper "mysql" - did you forget to enable it when you configured PHP?

(og har da skrevet inn <span style="color: rgb(0, 0, 0);"><span style="color: rgb(221, 0, 0);">mysql://brukernavn:passord@db.dittdomene.no/databasenavn<span style="font-family: Arial,Verdana,sans-serif;">)</span></span></span>

 

Har også Web10 som webhost, og har kontaktet dem, men de har ikke vært særlig hjelpsomme enda...

Har opprettet database i webgrensesnittet, men hakke peil på åssn jeg skal koble denne til Drupal eller om det trengs noen instillinger i PHPAdmin...

Svar på forumemnet

(If you're a human, don't change the following field)
Your first name.
Innholdet i dette feltet blir holdt privat og vil ikke bli vist offentlig.