Drupal feilmelding, hvordan deaktivere register globals?

HaukC
HaukCs bilde
Avlogget
Ble med: 03.01.2010

Heisann!

Nå nærmer jeg meg her. Har fulgt videoen, og installert Drupal til punkt og prikke, men får opp følgende feilmelding når jeg laster inn på mitt webhotell fra HostGator, med norsk Drupal-installasjon:

Uoppfylt forhåndskrav

Følgende feil må rettes før du kan fortsette med installeringen:

register_globals er aktivert. Drupal krever at denne konfigurasjonsinnstillinga er deaktivert. Nettstedet ditt kan være usikkert når register_globals er aktivert. I PHP-maunalen finner du informasjon om å forandre konfigurasjonsinnstillinger. (Bruker «Register globals»-instilling for PHP Aktivert ('1'))

Hva er galt? Prøvde å lese meg til det, men du kjenner meg etterhvert, jeg forstod ingenting.

 

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Skru av register globals i cPanel

For å skru av register_globals må man endre instillingene i php.ini. Hos HostGator har du cPanel, og der kan du endre innstillingene i php.ini via kontrollpanelet. Avhengig av hvilken versjon av cPanel du har, er fremgangsmåten forskjellig. En av de påfølgende metodene skal imidlertid fungere.

1. Deaktiver register_globals

  1. Logg inn i cPanel
  2. Gå til php.ini konfigurasjon (php.ini Configuration el.l)cPanel PHP configuration
  3. Aktiver med knappen "Enable" får å aktivere diverse options
  4. Skru av register_globals

2. Deaktiver register_globals

  1. Logg inn i cPanel
  2. Gå til Service Configuration
  3. Dernest videre til PHP Configuration Editor
  4. Der har du muligheten til å skru av register globals.

Skru av register globals

Husk å lagre instillingene før du prøver å installere Drupal igjen.

Svar på forumemnet

(If you're a human, don't change the following field)
Your first name.
Innholdet i dette feltet blir holdt privat og vil ikke bli vist offentlig.