Drupal feilmeldinger, default.settings.php

HaukC
HaukCs bilde
Avlogget
Ble med: 03.01.2010

Nå får jeg opp en ny feilmelding (herreguuuuud! :P). Feilmeldingen kom etter at jeg klikket av for norsk installasjon. Feilmeldingene sier:

Warning: fopen(./sites/default/default.settings.php) [function.fopen]: failed to open stream: No such file or directory in /home/haukc/public_html/includes/install.inc on line 188

Warning: Cannot modify header information - headers already sent by (output started at /home/haukc/public_html/includes/install.inc:188) in /home/haukc/public_html/includes/install.inc on line 618

Warning: Cannot modify header information - headers already sent by (output started at /home/haukc/public_html/includes/install.inc:188) in /home/haukc/public_html/includes/install.inc on line 619

som tyder på at det er noe feil en plass....

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
default.settings.php mangler

Feilmeldingene du får er "etterfølgere" av den første feilmeldingen:

Warning: fopen(./sites/default/default.settings.php) [function.fopen]: failed to open stream: No such file or directory in /home/haukc/public_html/includes/install.inc on line 188

Denne indikerer at du mangler filen default.settings.php. For å sjekke dette; gå inn i FTP, og se til at du har disse to filene liggende i katalogen sites/default/

  1. settings.php (redigert med dine databasedetaljer)
  2. default.settings.php (uredigert versjon)

Hvis du ikke har default.settings.php på webhotellet, overfør den fra den lokale katalogen på PCen din.

Hvis du har byttet navn fra default.settings.php til settings.php lokalt, bytt navnet tilbake og last det opp slik at du har både settings.php og default.settings.php i katalogen sites/default/

Anonym
Anonyms bilde
hva gjør jeg?

Failed to connect to your MySQL database server. MySQL reports the following message: Access denied for user 'hobbymarked_com'@'srv165.one.com' (using password: YES)

Dette kommer opp når jeg åpner hjemmesiden min. Hva gjør jeg? Har one så skrev inn localhost som i filmen!! Hva må jeg gjøre?

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Prøv å logge på MySQL via phpMyAdmin

Hei, er du sikker på at du har skrevet inn korrekt passord? Får du logget på MySQL med brukernavn og passordet du har brukt via phpMyAdmin på http://dbadmin.one.com ?

Anonym
Anonyms bilde
re

Nei kommer ikke inn der. Hvor finner jeg det passordet da.? har bare prøvd de jeg laget selver ganske grønn på dette!

 

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Databasepassord

Hvis du ikke kommer inn der med passordet ditt, så er det fordi du bruker galt passord. Da du kjøpte webhotell fikk du en epost som inneholdt diverse informasjon, blant annet passordet til databasen. Finner du det?

Anonym
Anonyms bilde
re

Fikk fikset det. takk for hjelpen

 

unn
Anonyms bilde
settings.php

Hei

Eg kjem nesten inn, men etter å ha vald språk får eg denne feilmeldinga.

Dersom eg kopierer fila og endrar namn kjem eg ikkje inn i det heile.

Kva kan dette vera?

Uoppfylt forhåndskrav
Følgende feil må rettes før du kan fortsette med installeringen.:
Som en del av installeringen til Drupal, må du opprette en fil for en del grunnleggende innstillinger.

   1. Kopier fila ./sites/default/default.settings.php til ./sites/default/settings.php.
   2. Sett filtillatelsene slik at vevtjeneren kan skrive til fila. Hvis du ikke vet hvordan du setter tillatelser for filer, se håndboka (på engelsk).

Du finner mer om å installere Drupal i INSTALL.txt.

Sjekk feilmeldingene og prøv igjen.

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Et par spørsmål

Et par spørsmål for enklere å kunne hjelpe deg:

  1. Har du fulgt videoguiden til punkt og prikke?
  2. Har du både settings.php og default.settings.php i katalogen /sites/default/?
  3. Hvor har du webhotell?

Hvis du svarer nei på nummer 2, så må du sørge for å ha begge filene i katalogen, prøv så igjen.

unn
Anonyms bilde
hei igjenja eg har begge

hei igjen

ja eg har begge filene i katalogen og og har webhotell hos one.com

 

Unn

unn
Anonyms bilde
meir feil

Hei hei

no er feilmeldinga borte, men prosessen stoppar opp ved installer nettsted. hovedruta er nesten tom, der står kun "home"

 

Unn

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
URL?

Kan du gi meg adressen til websiden din?

unn
Anonyms bilde
 icelott.com

 

icelott.com

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Last opp alle filer på nytt

Når jeg går inn der kommer jeg bare til en helt hvit side. Det er med andre ord ingenting på den. Anbefaler at du laster opp alle filene til webhotellet på nytt, jeg.

Tom
Anonyms bilde
feilmelding

Hei.

Site på andre dagen no og får fortsatt opp samma feilmeldingen.

Eg har,sletta, lagt inn og dobbeltsjekka sikkert 100 ganger men kvar gang er det same teksten.

" The Drupal installer requires that you create a settings file as part of the installation process.

  1. Copy the ./sites/default/default.settings.php file to./sites/default/settings.php.
  2. Change file permissions so that it is writable by the web server. If you are unsure how to grant file permissions, please consult the on-line handbook.

More details about installing Drupal are available in INSTALL.txt. "

 

Eg gir snart opp heile skiten.

domenet mitt er. babtasa.com, har webhotell hos one.com og eg har begge settings mappene i defaulten (den kopierte og originale)

 

Håpa du har peiling på ke det kan vera.

 

mvh Tom.

Ole Martin
Ole Martins bilde
Avlogget
Ble med: 15.06.2010
Enkelt!

Gjør dette enkelt.

I mappen "sites/default" ligger det en file: (drupal 5 og 6. i versjon 7 er det annerledes)

 

Etter at du har lastet opp alle filer vil du ha en fil som heter "default.settings.php" i denne mappen

  1. Døp den om til "settings.php"
  2. Last opp igjen "default.settings.php", da har du begge.
  3. Ikke rediger noe i filene, det gjør drupal selv ved installeringen. redigering skjer i så tilfelle i etterkant hvis du trenger det.
  4. Gi mappen "sites" og "default" og "settings.php"cmod (rettigheter) 777
  5. Når du har installert, tilbakestill cmod til
    1. 777 på "sites",  for drupal lager en katalog der som heter "files" som også skal være "777"
    2. 775 på "default"
    3. 644 på filen "settings.php"

 

- gi en fisk til en person, og personen blir mett èn gang
-lær personen å fiske, og personen blir alltid mett

tojja
Anonyms bilde
får ikke åpnet siden for installering!

Hei!

Lager min første hjemmeside, har fulgt videoen til punkt og prikke. mn når jeg skriver inn install.php i adresselinja i nettleseren er den fortsatt hvit. Har begge settings filene: default.settings og settings i default mappa. HJELP!

Hallvard
Anonyms bilde
problemer

hei!

Jeg prøver å sette opp min egen hjemmeside, men sliter skikkelig. jeg fulgte den videoen med innstallering av drupal på denne siden, men ble aldri kvitt den feilmeldingen med internal server error. i min frustrasjon har jeg prøvd meg litt frem og kom over denne videoen: http://www.youtube.com/watch?v=lYTPm8GnFFo

Jeg fulgte det som ble gjort på youtubevideoen og kom nå inn og fikk installert drupal. Drupal ser ut til å fungere fint og jeg har klart å publisere en artikkel, men det er jo ingen som kan se den?. Det ser ut til at jeg er avhengig av wamp for å komme inn på siden min. jeg kan ikke komme inn ved å skrive domenenavnet i nettleseren. Da får jeg opp internal server error. Så hvis jeg skal inn på drupal/nettsiden min må jeg først logge på wamp og så skrive localhost/drupal i nettleseren. Hva må jeg gjøre for at jeg kan logge inn uten wamp og hva må jeg gjøre for at andre kan se siden min?? 

Får kontakt med nettsiden på filezilla. der er det de filene som er lagret i wamp mappen som vises. Er dette av betydning?

Jeg er rett og slett helt lost, all hjelp tas imot!

Ole Martin
Ole Martins bilde
Avlogget
Ble med: 15.06.2010
For at andre skal se websiden

For at andre skal se websiden din må den ligge på en webserver som er tilkoblet internett sjenerelt. Det finnes måter der du kan dele din side med andre selv om den er installert på egen maskin/server. Er det dette du vil bør du søke litt rundt om. 

Alle mine sider ligger på en webserver tilhørende et webhotell, kun testinstallasjoner ligger på egen maskin

- gi en fisk til en person, og personen blir mett èn gang
-lær personen å fiske, og personen blir alltid mett

Anonym
Anonyms bilde
hva vil det si da? jeg har

hva vil det si da? jeg har webhotell hos bluehost hva må jeg gjøre for at siden alltid skal være tilgjengelig da? jeg har ikke noen spesiell interesse av at siden min skal være installert på min maskin/server.. vil gjøre det enklest mulig;)

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Installert Drupal lokalt?

Hehe, har du installert wamp på maskinen din, og så installert Drupal vha "localhost" osv? Ut fra det du sier, kan det i alle fall virke slik. Dvs; du har ikke installert Drupal på webhotellet, men lokalt på din egen maskin.

Hvis du logger på webhotellet ditt hos Bluehost (via FTP), ser du da filene til Drupal?

Kriz
Krizs bilde
Avlogget
Ble med: 29.04.2010
flytte drupal mappen kanskje

Jeg er sikkert ikke den mest kompetente til å svare her men kan prøve å hjelpe. Hva om du i Filezilla flytter/ kopierer alt innholdet i mappen wamp ut til roten eller katalogen som du har fått av ditt webhotell hvor din hjemmeside skal ligge for å vises?

Jeg husker jeg slet med min innstallasjon og fikk også den meldingen, husker ikke i hvilken forbindelse men tror det var når jeg skrev feil i php.settings eller glemte å åpne for skriving (777). Noen ganger slettet jeg bare alt og begynte helt på nytt og fulgte videoen på denne siden nøye. Du skal jo ikke trenge å bruke wamp server slik jeg forstår ditt ønske i og med at du har kjøpt deg et webhotell og domene.

Hallvard
Anonyms bilde
Hei igjen:) Takker for all

Hei igjen:)

Takker for all hjelp sålangt! Jeg har nå prøvd å slette alt å begynne på nytt, problemet er at jeg aldri blir kvitt den feilmeldingen; 500internal server error. Jeg har gått inn i htaccess og forandret linje 11 og 14, men feilmeldingen kommer likevel.. har også kopiert slik at jeg har både settings.php og default.settings.php. jeg har bare forandret settings.php filen ved å skrive inn mysql. i tillegg har jeg forandret file permissions fra 644 til 777 i filezilla på settings.php filen. Hva skal jeg gjøre? :)

 

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Noen spørsmål for å rette feil

Hei, er det deg som har lagt inn dette i wamp? I såfall; du må legge Drupal på webhotellet, dvs hos Bluehost. Har du gjort dette?

Hvis du har lagt Drupal hos Bluehost; hvilken katalog har du brukt?

Prøv å slette .htacces-filen (ha backup kopi lokalt!) i webrooten på webhotellet. Gå så til domenet, hva skjer?

En figur hadde et lignende problem med internal server error ved installasjon av Drupal tidligere. Du kan lese mer om det ved å følge linken, men jeg kan ikke garantere at .htaccess-fila i mitt innlegg der er like relevant lenger(!).

Hallvard
Anonyms bilde
Hei, ja det var jeg som hadde

Hei, ja det var jeg som hadde lagt det inn i wamp, lite gjennomtenkt. Jeg skjønner ikke helt spørsmålet med hvilken katalog jeg har brukt når jeg la drupal hos bluehost. Det jeg gjorde var at jeg slettet det som var lagret på bluehost serveren i utgangspunktet for å starte med tom server, slik jeg så at du hadde i videoen. (har backup) Så kopierte jeg alle filene fra drupalmappen og overførte de til bluehost serveren. jeg har ikke opprettet noen katalog å lagt drupal inn i eller noe sånt :s det gjorde jo ikke du på videoen heller så vidt jeg har fått med meg. så alle filene ligger "spredt" på serveren.

Jeg prøvde å slette .htaccess filen. det som skjedde da var at jeg fikk en annen feilmelding:

Not Found

The requested URL / was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache Server at ******.com Port 80
Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Legge Drupal på webhotell

Da har du gjort feil. På videoen legger jeg inn Drupal på et webhotell fra One (jeg har mange webhotell). Det du må gjøre er å legge filene som tilhører Drupal i den såkalte webrooten din.

Hvis du ser på det første bildet i denne guiden om hvordan lager FTP-konto på webhotell fra Bluehost, så ser du jeg har markert webrooten der.

Hallvard
Anonyms bilde
what to do

Jeg har fått det til nå:) Tusen takk for all hjelp! Jeg er nå i gang med å lage nettsiden min takket være hjemmeside.org!

Bjarne
Anonyms bilde
Endret passord for Mysql

 Hei!

Fikk beskjed fra webhotellet mitt (domeneshop) at fila settings.php var lesbar for alle. De hadde da endret rettigheten slik at bare jeg skulle kunne lese den, og jeg ble anbefalt å endre passordet til databasen og til innloggingen til hjemmesida (slikt.net, drupal). Jeg endret passordet til databasen, og nå får jeg beskjed om at nettstedet mitt er off-line hvis jeg prøver å skrive slikt.net.

Hva kan jeg gjøre? Jeg får ikke lov til å endre passordet på databasen tilbake til det gamle.

Ellers takk for et flott nettsted; fikk meg igang med å mekke hjemmeside:)

Bjarne
Bjarnes bilde
Avlogget
Ble med: 30.12.2010
Endret passord for Mysql

 Da har jeg meldt meg inn i hjemmeside.org. Håper på svar på meldingen over, og at det går an å løse problemet uten å installere Drupal på nytt.

Bjarne
Bjarnes bilde
Avlogget
Ble med: 30.12.2010
Endret passord for Mysql

Hei!

Se forrige meldinger. Klarte å fikse dette selv ved å sette nytt passord manuelt i settings.php. Er nå oppe og går igjen! (Nettstedet altså) 

signe
signes bilde
Avlogget
Ble med: 05.11.2011
Hjelp

Ser forrige post her er over et år gammel, men jeg prøver meg alikevel :)

 

Nå har jeg fulgt alt av videoer jeg har funnet her inne. Har lastet ned drupal og Filezilla, og kjøpt webhotell fra bluehost som anbefalt her inne. Jeg har fulgt alt til punkt og prikke og fortår ikke hvorfor det ikke virker.

Jeg tenker at jeg muligens har missforstått hvilket brukernavn/passord som skal legges inn i den tilleggssetningen i settings.php, men har prøvd alle jeg har :/ ...

Jeg har forresten også både settings.php og default-varianten av den, samt at jeg har redigert .htaccess som vist i videoen, men jeg får alikevel opp den samme feilmeldinga... hva gjør jeg galt?

Håper virkelig på svar da jeg har forsøkt i timesvis uten hell :/

signe
signes bilde
Avlogget
Ble med: 05.11.2011
fortsettelse følger

Jeg opprettet en ny FTP-bruker/konto i databasen på cpanel og byttet ut brukernavnet og passordet inne på settings.php med de nye, og når jeg nå forsøker å åpne nettsiden min så kommer det:

"Index of

/User"

 

Skjønner virkelig ikke hva som skjer :P ... Hvilket hostnavn er det egentlig som skal stå inne på settings.php forresten, det skjønte jeg aldri, men har til gjengjeld forsøkt alle  alternativer :/

domenenavnet er jusstudier.com hvis noen med peiling orker å ta en titt :)

Kriz
Krizs bilde
Avlogget
Ble med: 29.04.2010
Hei Signe,   hvilke

Hei Signe,

 

hvilke feilmelding får du? Du kan jo også la være å redigere i settings.php, men da må du legge inn passord og brukernavn under installasjonen.

 

Kristian 

signe
signes bilde
Avlogget
Ble med: 05.11.2011
Feilmeldingen som dukker opp

Feilmeldingen som dukker opp på nettsiden ser slik ut:

Index of / Apache Server at jusstudier.com Port 80     Jeg har aldri holdt på med noe slikt før så mistenker at jeg er på dyyyypt vann her :)   Jeg har fulgt videoene så nøyaktig som jeg bare klarte, det eneste eg var litt usikker på var hvilke brukernavn, passord og host som skulle inn i den linja i settings.php... opprettet jo ett for både bluehost, databasen og FTPkonto sånn som jeg forstår det....? :)
Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Oppdatert videoguide

Jeg har lagt ut en oppdatert installasjonsvideo for Drupal 6 med norsk språk, se på den.

signe
signes bilde
Avlogget
Ble med: 05.11.2011
Nå har jeg fulgt den

Nå har jeg fulgt den oppfaterte videoen. Og jeg sitter fast på nøyaktig samme sted som tidligere.

 

Når jeg kommer til ca 7:50 i videoen og skal åpne hjemmesiden så får jeg samme beskjed som før:

 

Index of /
  • user/
Apache Server at jusstudier.com Port 80

 

Når jeg da trykker på "user/" så ser siden slik ut:

 

Index of /user
  • Parent Directory
Apache Server at jusstudier.com Port 80   Bare for å teste så skrev jeg et tillegg på url'n så den ble slik:  jusstudier.com/user/install.php   Da kom jeg inn på drupalsiden for å registrere e-post, passord osv. men når videoen kommer til ca 10:30 og jeg skal åpne siden på nytt så ser den fremdeles identisk ut med de to feilmeldingene ovenfor...??? Flere tips?   Og beklager mas :/
signe
signes bilde
Avlogget
Ble med: 05.11.2011
På bedringens vei...

Nå har jeg funnet ut hvordan jeg skal klare å komme til administrasjonssiden. Mens det i videoene er domenenavn.com/install.php og domenenavn.com/admin som er url'ene så må jeg tydeligvis putte inn et "/user/" for å fo tilgang til de respektive sidene. Altså slik: domenenavn.com/user/install.php og domenenavn.com/user/admin.

Noen som vet hvorfor det har blitt slik? Nå er det ikke et stort problem for øyeblikket iom at siden er tom, men når jeg tar den i bruk så vil jeg jo gjerne at andre skal kunne se den ved å skrive bare domenenavn.com, og ikke måtte skrive /user/ over alt for å få tilgang...

Tips? :)

Svar på forumemnet

(If you're a human, don't change the following field)
Your first name.
Innholdet i dette feltet blir holdt privat og vil ikke bli vist offentlig.