Drupal, settings hos Domeneshop

torbjrnm
torbjrnms bilde
Avlogget
Ble med: 06.10.2010

Jeg sliter med settings.php og default.settings.php

Har kjøpt opp domene hos domeneshop og prøver å få inn Drupal der.

Er det passordet til MySql som skal inn i default.setting.php eller samme passordet som jeg bruker å logge på mot domenshop med FileZilla?

Følgende er under spørsmål og svar hos domeneshop:

Hvordan bruker jeg "mysql"-kommandoen fra et login-shell?

Logg inn med SSH på login.domeneshop.no med ditt brukernavn og passord. Deretter kan du benytte "mysql"-kommandoen slik:

mysql DATABASENAVN -uBRUKERNAVN -pPASSORD -hDATABASENAVN.mysql.domeneshop.no

Databasenavn, brukernavn og passord fikk du tilsendt da MySQL ble aktivert på webhotellet. For litt hjelp til bruk, tast "help". For å avslutt......

Sier det ovenstående noe om formen på det jeg skal skrive inn i settings.php?

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Problemer hos domeneshop

Hei, var det deg som hadde problemer med MySQL og 500 error hos Domeneshop?

torbjrnm
torbjrnms bilde
Avlogget
Ble med: 06.10.2010
ikke error 500

Jeg har ikke fått error 500 hos domenshop, men errer 404.

Har skrevet mere som svar hos Thomas, som også har problemer med Drupal hos Domenshop.

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Drupal hos Domeneshop

Ok, du skal uansett ikke bruke den kommandoen der for å koble på MySQL fra PHP (dvs; i Drupal). Den kommandoen der er fra et såkalt shell.

Har du fått opp hjemmesiden din enda, eller har du problemer med å koble på databaseserveren? I såfall, hva har du skrevet i settings.php?

torbjrnm
torbjrnms bilde
Avlogget
Ble med: 06.10.2010
får koblet på

Jeg bruker FileZilla og med det får jeg lastet opp bilde til siden min som er: www.topfuel.no

I 1 tilfelle startet installasjon av Drupal, men så kom det opp flere feilmeldinger, som jeg desverre ikke noterte. Mener jeg brukte:

  1. $db_url = mysql://topfuel_no:(passord)@localhost/topfuel_no';

men er ikke helt sikker

Jeg har forskjellig passord for Mysql databasen og det jeg bruker i FileZilla for å logge på. Hvilket skal jeg bruke?

Skal Drupal legges i katalog: /www, eller ikke?

Prøvde nå med det som står over her i settings.php, da kommer følgende opp på siden:

Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.

Error 404

www.topfuel.no

Thu Oct 7 16:03:44 2010

Apache/2.2.16

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Koble til MySQL

Hei igjen.

  1. Du skal bruke MySQL-brukernavnet og MySQL-passordet. Det andre passordet er til FTP.
  2. Hvis du har MySQL hos domeneshop, så tror jeg hosten din er noe annet enn "localhost". Sjekk egen mail el.l for å finne ut hva din host er, og erstatt "host" i linja under.
  3. Du skal bruke $db_url = mysql://bruker:pass@host/databasenavn';
  4. Drupal skal legges i www-katalogen.
torbjrnm
torbjrnms bilde
Avlogget
Ble med: 06.10.2010
host står ikke

Host står det ikke noe sted i mail om min MySQL fra Domenshop.

Limer inn fra mail om min MySQL-database:

  • Server: topfuel.mysql.domeneshop.no
  • Database: topfuel
  • Brukernavn: topfuel
  • Passord: (passord)
Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Joda, host er server

Prøv med;

$db_url = mysql://topfuel:<pass>@topfuel.mysql.domeneshop.no/topfuel';

Husk å fjerne annet krimskramseri du har funnet på å plotte inn i settings.php, hehe. Du fjerner selvsagt < og > rundt passordet.

torbjrnm
torbjrnms bilde
Avlogget
Ble med: 06.10.2010
Tusen takk

Underet har skjedd ;-) Nå fungere installasjon av Drupal på siden min

Takker og bukker

Thomas
Thomass bilde
Da lurer jeg på hva du har gjort :)

Jeg har hatt "nesten" samme problemet som deg.

Lurer på om du kan ta det litt "step by step" hva du har gjort.

Du har endret følgende i .htaccess:

# Don't show directory listings for URLs which map to a directory.
#Options -Indexes

# Follow symbolic links in this directory.
#Options +FollowSymLinks

I tillegg så har du kopiert defalut.settings.php, og renamet den til settings.php

Åsså har du lagt inn følgende frase i settings.php:

$db_url = mysql://topfuel:<pass>@topfuel.mysql.domeneshop.no/topfuel';

Er det mer du har gjort?

La du disse inn under rota på webhotellet, eller under /www?

Kanskje jeg bør prøve med FileZilla istedenfor FlashFXP.....

torbjrnm
torbjrnms bilde
Avlogget
Ble med: 06.10.2010
Det stemmer

Alt som står over her stemmer med det jeg har gjort.

i .htacces har jeg satt # foran Options -Indexes og Options +FollowSymLinks, så det står:  

# Don't show directory listings for URLs which map to a directory. #Options -Indexes # Follow symbolic links in this directory. #Options +FollowSymLinks

Har lagt ALT i katalogen /WWW

Bruker passordet for MyQSL i settings.php og ikke det samme som jeg logger på med ellers fra FileZilla eller på siden nå og da ser det sånn ut:

$db_url = 'mysql://topfuel:<passord>@topfuel.mysql.domeneshop.no/topfuel';

 

ducatien
ducatiens bilde
Avlogget
Ble med: 11.11.2010
problemer med noe av det samme her

jeg har problemer med noe av det samme som over..tror jeg

 har gjort dette i settings.php:

  1. $db_url = 'mysql://username:password@localhost/databasename';
  2. $db_url = 'mysql://www.4racing.no:passord@win02.uniweb.no/w142885';
  3. $db_prefix = '';

Uniweb er min webhotell leverandør og de ga meg denne infoen:

Vertsnavn: win02.uniweb.no
Brukernavn: w142885
Passord: "Passordet" noe helt annet enn det jeg bruker i settings.php

er jeg helt på jordet..når jeg prøvde å kjøre med orginal "default.settings.php" omdøpt til settings.php fikk jeg opp hjemmesida som hvit.

Når jeg prøvde på den settings.php øverst på sida her så fikk jeg: HTTP Error 500

Jeg er grønn når det gjelder dette...har prøvd i hue og litt til...lest og sett video til øya er som ramma her..

Noen som vet

mvh

ducatien

 

Fixet............det var jeg selv som hadde gjort noe galt i MYSQL når det gjaldt passord.....i tillegg hadde jeg windows server...det måtte gjøres om til linux server for at jeg skulle kunne bruke PHP og DRUPAL.

Har webhotell og server hoa UNIWEB.no

 

Mvh

ducatien

Svar på forumemnet

(If you're a human, don't change the following field)
Your first name.
Innholdet i dette feltet blir holdt privat og vil ikke bli vist offentlig.