Får ikke kontakt med MySQL ved installasjon av Drupal

haaerdal
haaerdals bilde
Avlogget
Ble med: 07.10.2013

Hei

Har nå byttet til domene på Bluehost fordi jeg trøblet med Domeneshop, men Murphy er tydeligvis ute i dag og...

Jeg har oppgitt databasenavn og brukernavn og lar resten stå til default men får likevel:

Access denied for user 'erdaltes_ergo'@'localhost' (using password: YES).

Jeg har nettopp vært inne i cPanel og satt nytt passord på brukeren. Kopierte passordet fra bekreftelsessiden så det er HELT SIKKERT riktig!

Hva annet kan jeg ha gjort feil?

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Får ikke kontakt med MySQL ved installasjon av Drupal

Hehehe, uheldig skal man være. glis

Først: Sjekk at du ikke har med et mellomrom eller liknende i det du kopierte. Ofte når man kopierer passord, så er det en ekstra space eller tab. Prøv f.eks. å kopiere passordet, lim det inn i notepad (notisblokk) og kopier det derfra. Da sikrer man at man ikke har med formatering heller. Hvis du f.eks. kopierer noe som står i tykk skrift, så kan formateringen følge med på kjøpet.

Hvis ikke dette fungerer, prøv følgende: Last ned settings.php fra webhotellet. I denne filen går du til linje 91. Der ser du dette:

  1. $db_url = 'mysql://username:password@localhost/databasename';

Skift ut dette med de faktiske dataene dine, det vil si brukernavn, passord, host og databasenavnet. Lagre deretter og overskriv den gamle settings.php på webhotellet.

Hos Bluehost skal host stå som "localhost", dersom de ikke har forandret på dette nylig.

haaerdal
haaerdals bilde
Avlogget
Ble med: 07.10.2013
Får ikke kontakt med MySQL ved installasjon av Drupal

Fant ut av det. I min iver etter å lage et sikkert passord kom jeg i skade for å bruke " som et av tegnene. Bluehost godtar det når man oppretter en databasebruker, men når dette havner i settings.php så blir det trøbbel. Takket være fargekodet editor var det enkelt å oppdage når jeg forsøkte å skrive inn $db_url.

Så altså: IKKE bruk " (shift+2) i passordet når du oppretter en MySQL databasebruker på BlueHost.

Svar på forumemnet

(If you're a human, don't change the following field)
Your first name.
Innholdet i dette feltet blir holdt privat og vil ikke bli vist offentlig.