Får ikke logget inn i Admin (Drupal)

HaukC
HaukCs bilde
Avlogget
Ble med: 03.01.2010

Hei,

Sliter med å logge inn i adminpanelet i Drupal etter å ha lagt inn theme fra MonsterTemplates.

Har prøvd å logge inn både via hovedside og med /user. Hva kan være galt?

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Mulige måter å få logget inn på
  1. Hva slags feilmelding får du, hvis noen?
  2. Har du prøvd å få tilsendt nytt passord?
  3. Prøv å fjerne alle cookies i nettleseren og forsøk 1 & 2 igjen.
HaukC
HaukCs bilde
Avlogget
Ble med: 03.01.2010
1) Får oppAccess denied You

1) Får opp

Access denied

You are not authorized to access this page.

2) Har prøvd å få tilsendt nytt passord ja, men den virker ikke å sende ut nytt...

3) Done, several times.

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Autentiseringsproblemer

Hmmm, sikker på at mailene med det nye passordet (eller rettere sagt direktelink til resetting av passord) ikke havner i spam?

Hva skjer om du oppretter en ny bruker? Får du tilsendt mail med innloggingsdetaljer? Får du logget på med den nye brukerkontoen?

HaukC
HaukCs bilde
Avlogget
Ble med: 03.01.2010
Klarer fint å lage ny bruker,

Klarer fint å lage ny bruker, så ser jo ut som det er et eller annet jeg har glemt med admin-login. Mener likevel jeg har brukt et fellepassord for alt når jeg har holdt på nå, og det funker liksom ikke. Ligger ingenting i spam i mail, men har sannsynligvis reg. en annen email :/

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Rediger databasen manuelt

Hvis du klarer å opprette nye brukere og systemet sender ut epost, så er det nok som du sier: Du har registrert noe annet på adminkontoen. OBS: Merk at administratorkontoen ikke nødvendigvis har brukernavnet admin. Brukernavnet satte du selv under installasjonsprosessen.

Det du kan gjøre er å gå manuelt inn i databasen til Drupal, sette en annen epost på adminkontoen og så be systemet sende deg de nye detaljene for adminbrukeren.

Husker i skrivende stund ikke hvilken webhost du brukte, men se om du har phpMyAdmin. Har du ikke det kan du som regel logge på MySQL via SSH ved å kjøre kommandoen nedenfor. Her er en guide for hvordan du logger på SSH.

:~$ mysql -h host.tld -u brukernavn -p

Du vil deretter bli promptet for pass, og kan oppdatere eposten til brukerkontoen ved hjelp av SQL.

For å bytte mail på adminkontoen, gjør følgende:

Logg inn i databasen som vist ovenfor. Deretter må du velge database. For å se dine databaser skriv:

mysql> show databases;

Du får da opp ei liste med dine databaser. Lokaliser din database og skriv inn:

mysql> use databasenavn;

Du har nå valgt database, og må finne ut hvorvidt du har satt en prefix på tabellene dine, type prefix_users.

mysql> show tables;

Du ser etter en tabell som heter prefix_users. Skriv så inn:

mysql> UPDATE prefix_users SET mail='min@epost.no' WHERE uid=1;

Du har nå oppdatert brukerkontoen med brukerid 1 med en ny epostadresse. Prøv å få tilsendt passordet gjennom password recovery funksjonen i Drupal nå.

Anonym
Anonyms bilde
Samme problem

Jeg har samme problemet: får ikke logget på admin.

Får denne meldingen:

Tilgang nektetDu har ikke tillatelse til å besøke denne siden.

 
Det er riktig brukernavn og passord, som jeg laget under installasjonen (bruker jeg feil brukernavn eller passord får jeg melding om at det er feil. Altså er brukernavnet mitt og passordet korrekt).
Anonym
Anonyms bilde
Re: Her også

When the install script succeeds, you will be directed to the "Welcome"page, and you will be logged in as the administrator already. Proceed withthe initial configuration steps suggested on the "Welcome" page."

Jeg var ikke allerede logget inn, og får heller ikke logget inn.

Anonym
Anonyms bilde
Re: Her også

Fjernet alle filer, og la de inn på nytt. Fikk likevel ikke installert på nytt. Fjernet på nytt alle filer og alle tabeller i sql databasen.La deretter alle filer inne på nytt, og gjorde som tidligere. Denne gangen kommer jeg ikke forbi denne meldingen:

Internal Server ErrorThe server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, support@one.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.More information about this error may be available in the server error log.

Når jeg endrer ".htaccess", og setter på "#"  der jeg skal, så endres den tilbake av seg selv med en gang. "#" blir borte.

Begynner å gi opp... Sittet med dette non-stop i 4 timer nå...

 

Anonym
Anonyms bilde
Re: Her også

Nå funket det plutselig. Kun gjort det samme om og om igjen.

Gleder meg til å teste dette ut;)

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Problemer hos one?

Hei, flott at du fikk det til, var bortreist da du slet med dette, så jeg fikk ikke svart. Har problemene gitt seg, eller har de kommet tilbake?

Dette kan ha kommet pga problemer hos one (som jeg ser du bruker i internal server erroren du viser til). Hvis du gjorde den samme prosessen og det plutselig begynte å fungere, så kan det nok være fordi de fikk fikset et problem.

Trådstarter brukte forøvrig HostGator, ikke one.

Svar på forumemnet

(If you're a human, don't change the following field)
Your first name.
Innholdet i dette feltet blir holdt privat og vil ikke bli vist offentlig.