Installere CKEditor i Drupal 6.24

Arne
Arnes bilde
Avlogget
Ble med: 29.02.2012

Har installert Drupal 6.24 kjerne. Har fulgt videoen for å installere CKEditor. Får denne meldingen:

The version of CKEditor could not be detected.
Extract the archive and copy its contents into a new folder in the following location:
sites/all/libraries/ckeditor

So the actual library can be found at:
sites/all/libraries/ckeditor/ckeditor.js

Har sjekka at filoverføringa er OK.

Fikk dette katalognavnet, ckeditor_3.6.2_for_drupal_6, etter utpakkinga av zip-fila. Måtte fjerne, _3.6.2_for_drupal_6, for å få overnevnte melding. Uten å endre filnavnet var det ingen reaksjon.

Forstår ikke hva som menes med siate linja i meldinga, det stemmer ikke med hva jeg ser på videoen.

Håper noen kan hjelpe meg!

Mvh Arne

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Installasjon av editor

Er du 100 % sikker på at du har lagt CKEditor i katalogene "sites/all/libraries/ckeditor"?

Den siste meldingen betyr at den ikke finner editoren i den angitte katalogen. Det kan hende at videoen er noe utdatert, der skjer jo utvikling på dette området hele tiden. Jeg skal gjennomgå videoene og sørge for at de er up to par.

I WYSIWYG API-modulen ligger det også en README-fil.

I denne står det (min oversettelse)

1) Installer som vanlig (her menes det at man skal laste opp modulen og aktivere den under "administrer -> moduler".

2) Gå til domene.com/admin/settings/wysiwyg og følg de angitte installasjonsanvisningene for den editoren du ønsker.

Du må med andre ord først installere WYSIWYG modulen. Deretter laster du ned editoren som er listet opp under linken i pkt. 2 over. Denne legger du så inn i katalogen "sites/all/libraries/ckeditor".

Arne
Arnes bilde
Avlogget
Ble med: 29.02.2012
Hei! Kan ikke se at jeg har

Hei!

Kan ikke se at jeg har gjort noe feil.

Men, aktiveringsboksen for WYSIWYG modulen er ikke aktiv, en svak hake syns så vidt, men kan ikke endres.

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Installasjon av CKeditor

Den er slik fordi den er aktivert. Grunnen til at den ikke er mulig å endre den, er fordi du også har aktivert en modul som er avhengig av den. Dette er med andre ord korrekt.

Hvis du logger på FTP og går inn i katalogen " sites/all/libraries/ckeditor/", ser du da en fil med navnet "ckeditor.js"?

Arne
Arnes bilde
Avlogget
Ble med: 29.02.2012
Nei! Fila "ckeditor.js"  ligg

Nei! Fila "ckeditor.js"  ligger her: "/sites/all/libraries/ckeditor/ckeditor/". Ingen av filene under "/sites/all/libraries/ckeditor/" har navnet  "ckeditor.js"  .

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Flytte filene

Da har vi nok funnet problemet ditt, Arne.

Er det slik at katalogen "ckeditor" kun inneholder en ny katalog som heter "ckeditor"? I såfall: flytt alle filer fra "ckeditor/ckeditor" katalogen til "ckeditor".

Forsøk så å gå tilbake til administrasjonen av WYSIWYG, på domene.com/admin/settings/wysiwyg og se om ikke det gjør saken biff.

Det er ikke noe farlig om dette slår seg vrangt, man kan alltids laste ned CKeditor igjen og laste den opp på nytt. :)

Arne
Arnes bilde
Avlogget
Ble med: 29.02.2012
Flytte filer

Nei, katalogen "/sites/all/libraries/ckeditor/" inneholder katalogen "ckeditor/ og flere kataloger og filer, men ikke fila "ckedito.js". Fila "ckedito.js" ligger i:  "/sites/all/libraries/ckeditor/ckeditor/"

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Flytt den ene filen en katalog opp

Forsøk å bare flytte den filen ett hakk opp da, slik at den ligger i den første "ckeditor"-katalogen.

Arne
Arnes bilde
Avlogget
Ble med: 29.02.2012
CKEditor

Takk for svaret! Det fungerte.

Men!!!!! Fulgte videoen videre, og dobbeltsjekka, men når jeg prøver å skrive ny artikkel vises ikke CKEditor. Er det flere feil i filene jeg lasta opp?

NB. Det var ingen avvik fra de bildene jeg så på videoen og de bildene jeg så i programmet.

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Husket inndataformat?

Har du husket å velge riktig inndataformat?

Under tekstboksen hvor du skriver nye artikler kan du velge inndataformat. Du må velge det inndataformatet du har satt editoren til å virke for.

Arne
Arnes bilde
Avlogget
Ble med: 29.02.2012
CKEditor

Ja, jeg har fukgt videoen.

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Ny guide i hvordan man installerer WYSIWYG og CKEditor i Drupal

Hei,

Jeg tror ikke vi kommer noe særlig lenger med dette, så jeg har laget en ny guide hvor jeg gjør denne prosessen så kort og enkel som mulig.

Sjekk den nye guiden som viser hvordan man innstallerer WYSIWYG og CKEditor i Drupal. Gi meg beskjed om det fungerer for deg.

Arne
Arnes bilde
Avlogget
Ble med: 29.02.2012
CKEditor

Hei!

Tusen takk for hjelpen!

Det fungerte med en gang.

Mvh Arne

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Flott at du fikk innstallert CKEdtor i Drupal

Dette var gode nyheter! Superdupert! :)

Det kan se ut til at hovedproblemet ditt var at du lastet ned CKeditor for Drupal 6, og ikke standardeditoren. Skjønner godt at dette kan skje. :)

Svar på forumemnet

(If you're a human, don't change the following field)
Your first name.
Innholdet i dette feltet blir holdt privat og vil ikke bli vist offentlig.