Øke memory_limit i PHP på webhotell fra BlueHost

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008

I PHP har man en innstilling som heter memory_limit. Hos Bluehost er denne satt til 32M (MegaByte) som default. Dette kan bli litt for lite noen ganger, og det er derfor anbefalt at man øker den.

Man bør prøve å øke den i følgende inkrementer 64, 96, 128. Det finnes flere måter å gjøre dette på. Her er de, rekkefølgen spiller en rolle (alternativ #1 er best osv).

  1. Endre memory_limit i php.ini
  2. Endre memory_limit i settings.php (Drupal CMS)
  3. Endre memory_limit i .htaccess

Du trenger bare å bruke en av metodene for å endre memory_limit i PHP.

Øke memory_limit i php.ini

På webhotell hos BlueHost har du mulighet for å lage en egen php.ini. For å lage denne, gjør følgende:

  1. Logg inn i cPanel
  2. Klikk deg inn på PHP Config under Software/Services
  3. Velg PHP5 (Single php.ini), og klikk Save Changes
  4. Klikk så på Install php.ini master file

I katalogen public_html har du nå fått filen php.ini.default, logg på med FTP, last ned filen til din datamaskin og slett den som ligger i public_html.

Endre navnet på filen fra php.ini.default til php.ini, lukk deretter opp filen i en tekst- eller kodeeditor (notepad går greit).

Finn frem til linjen som sier:

memory_limit = 32M

og skrift ut 32M med et litt høyere tall (Drupal anbefaler 128M).

Lagre filen, last den opp på webhotellet igjen og gå til http://domene.comadmin/reports/status

Hvis du har gjort det riktig skal Minnegrense for PHP være satt til 128M

Øke memory_limit i settings.php (Drupal)

Last ned filen settings.php fra katalogen sites/default. Lukk den opp i en teksteditor, og finn frem til følgende:

<?php
ini_set
('url_rewriter.tags',        '');
?>

Under denne legger du inn:

<?php
ini_set
('memory_limit',         '128M');
?>

Lagre filen, last den opp på webhotellet igjen og gå til http://domene.comadmin/reports/status

Hvis du har gjort det riktig skal Minnegrense for PHP være satt til 128M

Øke memory_limit i .htaccess

Sjekk først hvilken versjon du har av PHP. Dette gjør du ved å lage en fil som heter info.php. I denne filen skriver du bare inn:

<?php
phpinfo
();
?>

Last den opp på webhotellet og gå til http://domene.com/info.php

Du får da opp masse informasjon om PHP, finn versjonen og noter ned denne.

Last så ned .htaccess. Denne ligger i webrooten, hos BlueHost er webrooten katalogen public_html.

I Drupal har man forhåndsdefinert endel instillinger på bakgrunn av hvilken PHP-versjon man bruker. Hvis du ikke har Drupal, må du skrive inn dette selv.

Hvis du har PHP5 eller bedre, finn:

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

(for PHP4 på Apache 1 er det mod_php4.c, og for PHP4 på Apache 2 er det sapi_apache2.c).

Uansett; mellom disse innstillingene skriver du inn:

  ...
  php_value mbstring.encoding_translation   0
  php_value memory_limit                 128M
</IfModule>

Lagre filen, last den opp på webhotellet igjen og gå til http://domene.comadmin/reports/status

Hvis du har gjort det riktig skal Minnegrense for PHP være satt til 128M

Hallvard
Hallvards bilde
Problemer med settings.php

Hei, har prøvd tidligere å endre disse instillingene i settings.php, men da fikk jeg ikke lastet opp den redigerte php filen igjen fordi jeg fikk følgende feilmelding:

Respons: 553 Can't open that file: Permission denied Feil: Critical file transfer error

Jeg trenger også å forandre disse filene i settings.php fordi jeg skal laste opp video på hjemmesiden ved hjelp av videomodulen;

ini_set('post_max_size', 100); ini_set('upload_max_filesize', 100);

Siden det skjærte seg med settings.php prøvde jeg nå å heller gå veien med .htaccess filen. Problemet nå er at det ikke skjer noen forandring selv om jeg skriver inn det du skrev ovenfor:s Vet heller ikke om jeg kan sette post max size og upload max size i .htaccess filen uansett. Så det beste er jo om du klarer å finne ut hvorfor jeg ikke får lov til å laste opp ny versjon av settings.php-filen.

Et spørsmål til. Hvis jeg får til dette etterhvert, er det dumt å øke den til mer enn 128M? Jeg ønsker å laste opp filmer på siden ved hjelp av video modulen og har en film som er på 300Mb jeg ønsker å laste opp.. Er denne rett og slett for stor tror du?

 

Svar på forumemnet

(If you're a human, don't change the following field)
Your first name.
Innholdet i dette feltet blir holdt privat og vil ikke bli vist offentlig.