Problemer med å laste opp dokument til webhotell

goingpro
goingpros bilde
Avlogget
Ble med: 25.01.2012

Hei! 

Jeg er veldig fersk i dette her, holdt på under en uke:P

Uansett, jeg har skaffet meg webhotell hos bluehost. Prøver å laste opp html-dokumentet som jeg lagde gjennom en av videoene dine. Jeg bruker filezilla, og har skjønt at man på en eller annen måte skal dra over dokuemtene som man ønsker å ha på webhotellet, fra lokalt sted til server. Men i hvilken av mappene på serveren skal jeg legge dokumentet?

Det står bl.a. .cpanel .cpanel-datastore .htpasswords .mozilla acces-logs etc mail public_ftp

 

 

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Laste opp filer til webhotell

Ja, du skal dra det over. For at det skal være tilgjengelig må du legge det i "public_html" (uavhengig av om dokumentet er html eller bilde osv). Alt du legger i "public_html" er tilgjengelig via domene.com/navn-pa-fila.html

Du kan også høyreklikke på fila og velge last opp i stedenfor å dra den over.

goingpro
goingpros bilde
Avlogget
Ble med: 25.01.2012
Ah, takk takk! Sleit med å

Ah, takk takk! Sleit med å finne den mappa som heter public_html i stad, men nå som jeg gikk inn i filezilla på nytt lå den i lista, aner ikke hvorfor den ikke var der i stad men:P   Nå funker det i alle fall!

Også i samme slengen, i den fjerde videoen din under "Kode hjemmeside med HTML og design med CS, så prøvde jeg å få inn et bilde/logo på nettsiden, men bildet vil ikke vises. Vet du hva det kommer av?

 

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Absolutte og relative filbaner

Det kan være at du har angitt filbanen til bildet feil. Prøv med hele URLen, dvs. http://domene.com/bilde.jpg - og ha for all del lastet opp bildet.

Du kan bruke absolutte og relative filbaner ved bruk av filer.

goingpro
goingpros bilde
Avlogget
Ble med: 25.01.2012
Hmm, får det fortsatt ikke

Hmm, får det fortsatt ikke til :(  Prøver å få det til slik at bildet vises i nettleseren lokalt, men bildet vises ikke da engang. Jeg prøvde å legge bildet rett på C-disken, og koden for bildet jeg har skrevet er:

<img src="C:/logo.png" alt="">

Og bildet har jeg kalt      logo.png   .

Hvis jeg skriver noe i gåseøynene etter alt=      ,så kommer hvertfall teksten opp, men bildet vil ikke vise seg. Prøvde å lese om absolutte og relative filbaner men fant ikke løsningen

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Referanse til fil på webhotell

Du kan ikke bruke filbanen "C:/logo.png". Denne peker på filen lokalt, på harddisken med navnet C.

Prøv å laste opp html-dokumentet som referer til bildet og bildet i hovedkatalogen og bruk følgende kode:

<img src="/logo.png" alt="">

Da skal bildet komme.

Les deretter om filbaner igjen og prøv de forskjellige eksemplene som ligger der eventuelt.

Svar på forumemnet

(If you're a human, don't change the following field)
Your first name.
Innholdet i dette feltet blir holdt privat og vil ikke bli vist offentlig.