Problemer med visning av bilder i FCKeditor

grol
grols bilde
Avlogget
Ble med: 16.02.2010

Hei.

Jeg er newbee i drupal og etter å ha funnet deres eminente hjemmeside med opplæringsvideoer, fant jeg tiden moden for å prøve dette.

Jeg har installert 6.15 og fulgt dine videoer. Jeg bruker fckeditor og det ser ut til å funke bra helt til jeg skal lagre artikkelen med bilde og tekst. Så snart jeg trykker forhåndsvis eller lagre, forsvinner bildet. Er dette en kjent feil?

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Forslag til løsning for å se bilder

Hei Grol! Dette kan komme av restriksjoner hos webhosten din, la meg forklare hvordan du kan fikse det. :)

Når du laster opp filer via IMCE (gjennom FCKeditor) lagres filene i katalogen /sites/default/files/ (og eventuelle underkataloger av "files" som du har definert).

I katalogen "files" finner du også en fil ved navnet ".htaccess". Lukk opp denne filen i en teksteditor. Du vil da se følgende to regler:

Options None
Options +FollowSymLinks

Bytt ut disse til:

#Options None
#Options +FollowSymLinks

Nummertegnet angir at dette er kommentarer, dermed utelukkes de to reglene når .htaccess tolkes av webserveren.

Last opp den redigerte filen på webhotellet igjen (det kan hende du må slette den gamle før du kan laste opp den redigerte!)

Prøv så igjen og se om problemet ditt ble løst. Setter også stor pris på at du sier ifra om dette løste problemet ditt, slik at andre som møter på samme utfordring ser om det fungerer her. Er også fint om du forteller hvor du har webhotell, slik at folk som er hostet på samme webhotell lettere finner denne tråden.

grol
grols bilde
Avlogget
Ble med: 16.02.2010
Visning av bilder

Hei igjen og takk for veeldig kjapp tilbakemelding!

Dette forklarte dere veldig bra i videoen, og jeg måtte kommentere ut disse linjene for i det hele tatt å få lastet opp (vist) bilder til fckeditoren. Jeg får lastet opp bilder til editoren men ikke vist de i f.eks. artikkel.

Jeg har tidligere brukt MemHT's cms men det virker som om drupal er mye mer "byggevennlig" så jeg håper å skynde meg litt sakte når jeg prøver å lære meg oppbyggingen av drupal. Jeg benytter meg av One com webhost og mitt domene er http://www.sveip.org. Dette domenet blir hovedsaklig brukt til privat og "prøveområder" for prosjekter. Testområdet for drupal er http://www.sveip.org/drupal.

På forhånd tusen takk!

Sting
Stings bilde
Avlogget
Ble med: 11.01.2010
Hei!Jeg slet med det samme,

Hei!

Jeg slet med det samme, men oppdaget at jeg hadde vært inne i feil .htaccess! Nå funker det med bilder hos meg også - nydelig!

Imidlertid oppstod et nytt problem: formatering av innleggene ble helt mystisk! Se for eksempel i forumet (regner med at du finner siden uten at jeg reklamerer igjen? ) - tidligere var innlegget fra ThomasK flott oppstilt nedover - nå er det bare et herlig kaos! Any ideas?

Hjemmeside: www.arleeproductions.org

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Tillatte HTML-tagger i inndataformatet

Jeg så innlegget til ThomasK på siden din, ja. Se til at du tillater <p>-tags (avsnitt) i innholdsformatet brukerne i forumet nytter seg av.

Når jeg ser på markup for innlegget til ThomasK, så ser det ut til at <p>-taggene er strippet, dvs. fjernet.

For å legge til tillatte "merker", dvs HTML-tagger, klikker du;

  1. Administrer
  2. Inndataformater
  3. Konfigurer (inndataformatet forumbrukere nytter)
  4. Konfigurer fra toppmenyen
  5. Skriv inn <p> under "Tillatte HTML merker"

Sjekk så om innlegget vises korrekt etterpå.

Sting
Stings bilde
Avlogget
Ble med: 11.01.2010
Så enkelt. Genialt. TAKK!!!

Så enkelt. Genialt. TAKK!!!

Hjemmeside: www.arleeproductions.org

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Fjerning av img tag i filter?

Berre hyggeleg, prøver å være så rask som mulig når jeg er her, vet det er kjedelig å stå fast. :) Og, ja, Drupal er ekstremt byggevennlig, kan lage det meste med dette CMSet.

Filter som fjerner img-tag

Ok, det er en stund siden jeg laget videoen, så jeg var ikke sikker på om jeg hadde tatt med den delen. Har du lagt inn noe filter slik at bilder strippes vekk? Mao. kan det være noe i filterne som begrenser img-tags?

For å finne ut hvilke filter som er gjeldende:

  1. Gå til domene.com/admin/settings/filters
  2. Velg "konfigurer" for filteret du bruker på WYSIWYG
  3. Sjekk om "HTML-filter" er aktivert, hvis ja;
  4. Klikk på "Konfigurer" i fanen øverst
  5. Se om <img> er inkludert i "Tillatte HTML merker", hvis ikke plasser taggen der.

Hvis dette ikke er en løsning, forsøk å last ned .htaccess filen for å se om endringene i den fortsatt er gjeldende. Jeg er ikke helt sikker, men det kan hende den har blitt endret tilbake av CMSet el.l.

Alternativt kan du sende meg en epost med påloggingsinformasjon til en brukerkonto med adminrettigheter, så skal jeg se på det for deg. Vil da poste løsningen på hva jeg fant her etter jeg har mottatt epost og funnet problemet.

Anonym
Anonyms bilde
Bildeproblematikk

Hei igjen.

<img> var ikke blandt taggene så jeg la denne til, men det funker fortsatt ikke. Har sendt deg en epost med sti og admininfo til sidene.

Tuuusen takk for kjappe tilbakemeldinger!-)

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Admin uten rettigheter

Dette var særs merkelig. Har mottatt informasjonen og forsøkt å logge inn. Det gikk det, men du har ikke gitt brukerkontoen tilstrekkelig administrasjonsrettigheter. Jeg kan ikke redigere, legge til innhold eller sette noen instillinger what so ever.

Si ifra når du har gitt tillatelser nok til at jeg kan endre på ting da. Antar at du ikke er redd for noe, siden dette bare er en testinstall.

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Deaktiver støtte for BBKode

Jeg mener å ha funnet problemet ditt nå, så du trenger ikke å gi brukerkontoen du sendte meg rettigheter. Jeg fikk nemlig eksperimentert litt ved å bruke kommentarfeltet.

Du må la <img>-taggen stå, for den skal være der. Derimot må du gå inn i innstillingene i WYSIWYG for FCKeditoren og deaktivere støtte for BBKode. (Du husker den lange listen med alle options, hvor man kan velge hvilke knapper editoren skal ha, fra den listen deaktiverer du BBkode).

grol
grols bilde
Avlogget
Ble med: 16.02.2010
Visning av bilder

Deaktiverte BBkode men dette hjalp ikke. Oppdaget en feilmelding i administrer/instillinger/wysiwyg:

"warning: Parameter 1 to theme_wysiwyg_profile_overview() expected to be a reference, value given in /customers/sveip.org/sveip.org/httpd.www/drupal/includes/theme.inc on line 617."

Har nå opprettet en rolle som heter poweruser med alle rettigheter. Som sagt: Jeg er newbee på dette og måtte knote litt for å opprette denne rollen. Beklager dette.

Håper du har full tilgang nå!

Tuuusen takk igjen:)

grol
grols bilde
Avlogget
Ble med: 16.02.2010
Visning av bilder

Ooops. Ser ut til at det funker nå! Case closed!

Tuuuusen takk for flott og kjapp hjelp:-)

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Du hadde deaktivert på feil sted

Nei, det var meg som gikk inn og fikset det. Du misforstod det jeg sa om BBkode ovenfor. Du hadde deaktivert den i listen over moduler. Meningen var at du skulle gå inn på WYSIWYG, deretter på det inndataformatet du har satt editoren på og fjerne knappen for BBKode i FCKeditoren :)

Når jeg fjernet den fungerte det, men den feilmeldingen du får der kommer pga one har oppdatert til PHP 5.3, et annet medlem hadde det samme problemet for noen dager siden, og da løste vi det ved å bruke en dev-versjon av WYSIWYG inntil oppdateringen kommer i den testede releasen. Den feilmeldingen er uansett ikke farlig, så du vil bli kvitt den når du oppdaterer modulen ved senere anledning. Hvis du vil fikse problemet nå, så kan du lese hvordan ved å følge linken ovenfor.

grol
grols bilde
Avlogget
Ble med: 16.02.2010
Visning av bilder

OK. Selvsagt burde jeg forstått det, men det er veldig mye å forholde seg til på kort tid. Uansett: Tuuusen takk nok en gang, og jeg blir bare mer og mer imponert over Drupal jo mer jeg trykker.

Hjemmeside
Hjemmesides bilde
Avlogget
Bidragsyter
Ble med: 17.06.2008
Bare hyggelig å hjelpe deg :)

Bare hyggelig, Grol. Og, ja, Drupal er definitivt noe av det mest innovative som har kommet ut av open source communityet (kanskje etter Linux). Selv er jeg jo programmerer, og jeg må virkelig si jeg synes dette systemet er det mest elegante (programmeringsmessig) og brukervennlige jeg har sett.

Odd
Anonyms bilde
Visning av bilder i Drupal

Hei, får ikke frem bildene i en artikkel.

Jeg har redigert ".htaccess" filen her /sites/default/files/ og i rotmappen med følgende.

# Options -Indexes

#Options None
#Options +FollowSymLinks

men får fortsatt ikke opp bilder.

 

Jeg har lagt inn disse

  • WYSIWYG API
  • FCKeditor (2.6.3)
  • IMCE
  • IMCE WYSIWYG bridge
  • input format permissions

Men prøvde meg å legge in Ckeditor i stede for FCK, men det funket ikke opptilalt, så jeg slettet alt i libraries og la inn FCKeditoren og den funket bra den, men får ikke opp bilder. De kommer bare opp som en tom boks.

Har for øvring lagt inn bbcode, det er egentlig det hele jeg har gjort til nå i Drupal.

Hva kan jeg evt gjøre for å få fram bilder?

Odd

Odd
Anonyms bilde
Løsning

Hehe, var å redigerte i feil fil. Redigerte aldri i /sites/default/files/

Dette var løsningen i riktig fil:

#Options None

#Options +FollowSymLinks

Takk

Svar på forumemnet

(If you're a human, don't change the following field)
Your first name.
Innholdet i dette feltet blir holdt privat og vil ikke bli vist offentlig.